My Vehicle:change vehicle

Trailer Side Marker Lights Not Working

Question:

just installed the wiring kit and all of the lites work except the side marker lites...I have them connected to the brown wire. Just the brown going to black wire that is coming from the side marker lite.

Expert Reply:

It sounds like you do not have the side marker lights properly grounded. If the lights have a separate ground wire to attach to the trailer frame it will need to be connected to a suitable point on the trailer frame. The closer to the light the better.

If you light does not have a separate ground wire then it is grounded through the mounting holes and you will need to be sure that the light is mounted directly to the trailer frame and making a good connection.

Use a circuit tester, item # 3808 if you need one, to check the wires and lights to be sure the ground is securely connected and you have power.

expert reply by:
Robert G

Ask The Experts a Question >>




Products Referenced in This Question


Product Page this Question was Asked From


Similar Expert Q&A Pages

See More Q&A Expert Answers >>




^
About Us
photos and videos
1,056,204

Original Photos & Videos

Produced to make sure you know what you are getting and you get exactly what you need.

installations
35,570

Installations Completed

To make sure products work and fit the way they are supposed to.

etrailer call center
2,476,511

Phone Calls & Emails Answered

1,125,924 phone calls and 1,350,587 emails to help find the right solution.

etrailer training
400+

Average Hours of Product Training

We get to know our products firsthand so experts can better help you.

etrailer service
71

Years of Quality Customer Service

Assisting our neighbors and customers, face to face at the counter.

etrailer experts
193,357

Pages of Expert Information

Created to make sure you have all the answers to your questions, from real experts.