Troubleshooting Curt Echo Brake Controller that Only Works with Manual Override

Question:

I have the controller installed but it shows on the phone the brakes are activated. Once the brake pedal is pressed no movement on the brake ring on the app.works when manually activate

0

Expert Reply:

That would indicate there is something wrong with your trailer wiring most likely. You need to verify that both stop/turn signal circuits on your vehicle 7-way are working like they should. These are the circuits that tell the Curt Echo Mobile # C51180 you are applying the brakes. So if the controller isn't activating like it should that's where the problem would be. Typically this issue is caused by corrosion on the pins of the 7-way which can be sanded off but it could also be caused by a blown fuse.

expert reply by:
0
Jameson C

Product Page this Question was Asked From


Follow up Questions

Lisa A.

My echo brake controller is not lighting up to pair with bluetooth. This morning it come on, now nothing... No light at all 96778

Reply from Jon G.

If you look at the instructions for the Curt Echo # C51180 if the LED does not light then the Echo isn't getting power or there is no ground for the vehicle 7-Way. Check the power and ground for your vehicle side 7-Way and make sure that your tow vehicle has the trailer mode activated. Also check to see if your trailer needs to be connected for your vehicle to send power back to the 7-Way. 71402

Austin

My Echo does not seem to get power when I plug it in. My trailer brake lights and turn signals work fine though. I replaced my Echo with another but still have the same issue. Any ideas? 86365

Reply from Chris R.

Are you sure you're getting power at the 7-Way on the 12V circuit/pin? The Echo needs this circuit to be active because this is how it receives power. You may need to replace a fuse under the hood or manually activate this circuit by running a hot lead up to the vehicle's battery. 68218

David

I cannot get the brale controller to pair with my phone. Any suggestions? 80757

Reply from Chris R.

When pairing the Echo up to your phone make sure you are going through the Echo's app and not trying to connect through your phone's Bluetooth settings. This is very important and typically why this issue comes up. Let me know if you ARE going through the app and we'll go from there. 66499

Reply from Earle

I'm having the same problem. No blue light and no pairing. Worked the first time I used it and no more. Tried your suggestion and no luck. Any other ideas? 67862

Reply from Chris R.

I would try turning the Bluetooth on your phone off and back on again. Sometimes it just needs to be rest. Let me know if this doesn't work. 67894

Reply from Earle

Thanks. Did that first. The unit Curt unit appears dead. Will switch out to a different manufacturer. 67920

Earl S.

Sometimes the controller applies the trailer brake without me having applied the truck brake. Any fix for this? or, is there a way to quickly over ride the brake application? 77125

Reply from Chris R.

I would try adjusting the sensitivity level on the Echo (through the app on your phone). Sometimes it can be a little over-sensitive, sending power back to the brakes during slight deceleration, going up hills, etc. Adjusting this setting should keep that from happening but let me know if the issue persists. There isn't a way to quickly reverse/override braking if it happens when it shouldn't. 62845

Similar Expert Q&A Pages

See More Q&A Expert Answers >>