bing tracking image
Q & A Icon

Trailer Turn Signals Both Blink at the Same Time When Right or Left Turn Signal is Turned On

Question:

Installed the wiring harness and all went well. Tested the signals and all worked correctly at first, now both rt. and left signals blink at same time no matter which one I have on. Brake and running lights work properly. Thanks for any suggestions.

0

Expert Reply:

If both turn signals blinking at the same time is a new problem that has occurred after the harness had worked fine before, there are a couple of possibilities that may be causing the issue. First, the easiest thing to check are the trailer connectors. You will be looking for any dirt or corrosion build up in one or both connectors (vehicle and trailer side). Clean them out if you find any dirt/corrosion and see if that helps.

If you still have the problem, disconnect the trailer to test the 4-Way on the vehicle using a circuit tester like # 40376. First, test the wiring going into the convert box on # 118426 from the vehicle tail light wiring. If the signals are not correct then you have a problem with the vehicle wiring.

If the signals are correct going into the converter, test the wiring coming out for the correct signals. You would have to test by probing both turn signal wires with only the left or right turn signal in the vehicle turned on. If you find that the signals are incorrect coming out of the converter then the converter has gone bad and it will need to be replaced.

If the signals are correct coming out of the converter to the 4-Way then the issue is on the trailer side wiring. You will need to check the grounds at the trailer connector and the trailer lights. All grounds should be attached to clean, bare metal surfaces.

expert reply by:
0

Products Referenced in This Question


Product Page this Question was Asked From


Follow up Questions


Richard
Hi I have a 1969 Atwood Rv trailer it use to have Rv lights they were old so I replaced them with some new lights. When I had the old lights on everything worked fine now that I put the new lights during the day when I put the left hand signal on all the lights on the RV blink. The right had is fine, also my running lights at night work fine except the left hand signal it does not work. What can I do to fix this problem, any advice I checked the ground and the ground wire is ok thanks.
Etrailer Expert
Reply from Chris R.

It's hard to know exactly where the issue is on this setup. Did you only replace the light assemblies or did you re-do any wiring as well? If it's JUST new light assemblies, I would just make sure that each wire is securely connected and hooked up to the right circuit on the trailer. I know you checked the grounds but it still might be worth it to actually remove them, sand down the metal surface they're attached to, and re-attach.

Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>