View Cart

How to Troubleshoot a Trailer Blowing the Running/Taillight Fuse Only

Question:

i run about 7 trailers one trailer has me stumped, only lose tail lights, tail turn brake works. but unit will blow tail/running light fuse? what am i missing. using 7pin connectors

Expert Reply:

Since 6 of your trailers are not having problems with the 7-Way connector on your vehicle, the problem must be in the 7th trailers wiring. I would start with making sure all of the ground connections are securely attached to clean, rust and corrosion free surfaces, just to be sure, although it sounds like a short circuit issue.

Then, I would check the 7-Way trailer connector. Take it apart and check inside to be sure that the wire connections are not shorted somehow to the taillight circuit.

If that does not solve the issue, check all of the taillight wiring all the way down the trailer to be sure there is not a rubbed or frayed wire causing a short. If you have a boat trailer with the wiring inside the frame you will need to pull it out to check it. Attach a string so the wires can be pulled back through the frame when done.

If that does not work, you may have a bad light on the trailer. Remove each light one at a time until you find the one that solves the issue and replace it.

If these troubleshooting steps do not help let me know what you have come up with and some more info about the offending trailer and I will be glad to help you figure it out.

expert reply by:
Robert G

Ask The Experts a Question >>


Product Page this Question was Asked From