Troubleshooting Optronics Trailer Light part # STL68RB Reverse Light Circuit Doesnt Come On

Question:

Existing 1157/1156 assy works ok. Led tail, stop, turn functions work ok. But adding reverse wire, reverse light is always on. Reverse light only worKS correctly when tail and turn wires are disconnected. Whats up with this. I thought this would be simple.

0

Expert Reply:

The problem has to be in the wiring you are using, unless the light itself is defective which is most likely not the case.

I would recommend you take the light out and test each of the functions with a known working car battery. You can do this under the hood of your vehicle pretty easily. Ground the white wire to the negative terminal and then touch each of the remaining wires to the positive post of the battery. All of the light functions should work individually. Now try using more than one wire at a time on the positive side to see if you can get more than one function to work at a time. You should see all of the functions work now if the light isn't defective.

Now if the issue is still there when you go to wire up the light to your trailer you may have the wrong wires ran to the assembly. Using a circuit tester with the trailer connected and taillight functions applied test each of the wires so that you know what their function is and then wire according.

White wire is for ground
Brown wire for backup light
Red wire for brake light
Black wire for tail light

expert reply by:
0
Jameson C

Ask The Experts a Question >>


Product Page this Question was Asked From


Similar Expert Q&A Pages

See More Q&A Expert Answers >>