Troubleshooting Brake Controller Installed on 2010 Nissan Titan

Question:

I installed a pilot brake controller as it was described with a Nisson harness but i have no power or anything when i hit the brake the fuses seem all right what am i missing ???

1

Helpful Expert Reply:

If you are using the Nissan factory harness, the harness will not wire to the brake controller color for color. Check the way you have the controller wired to the factory harness, it should be wired like this:

Red Nissan Harness Wire to Black Brake Controller Wire
Red and Green Striped Nissan Harness Wire to Red Brake Controller Wire
Black Nissan Harness Wire to While Brake Controller Wire
Brown and White Striped Nissan Harness Wire to Blue Brake Controller Wire

If you have determined that the controller is wired properly, do a quick bench test on your controller using a circuit tester like part # 40376. If your controller is not getting power, you might have a fuse or relay missing in the fuse box which is typically located under the hood. I would also recommend checking your 7-way trailer connector for damage or corrosion. The trailer connector ground and each ground for you brake magnets should be checked as well. Make sure each ground connection is secure and not corroded.

I have linked you to a video showing how this is done. I have also linked you to a brake controller troubleshooting FAQ that should be helpful.

If you confirm that the controller has been wired properly, the 7-way is in good condition and the troubleshooting guide does not lead you to the problem, please get back with me and we will look in to some other possible causes of your problem.

helpful expert reply by:
1
Mike L

Products Referenced in This Question


Product Page this Question was Asked From


Follow up Questions

Similar Expert Q&A Pages

See More Q&A Expert Answers >>