bing tracking image
Q & A Icon

Troubleshooting Black Water Tank Sensors Giving False Readings

Question:

I own a 2007 Forest River Cardinal and I`m having a problem with my sensors in the black holding tank! I can clean the 40 gallon tank completely and the sensors will show that the tank is empty. Then add a 8 oz bottle of holding tank deodorant and the tank sensors shows to be 2/3 full. I`ve tried one other product to clean the sensors, but that didn`t help! I`m considering purshasing the Valterra Power Sensor Cleaner to see if it will work. Is the success rate of this product worth a trial? Could you let me know what the success rate of this product is and or is their another product that you recommend? I`ve been dealing with this problem since I`ve owned the RV!

1

Helpful Expert Reply:

We haven't received a lot of customer feedback regarding the Valterra Sensor Power Sensor Cleaner # V22011 that you referenced so I can't really provide an accurate success rate. The treatment is specifically designed to clean the sensors in an RV's black water tank to help correct those incorrect readings you keep getting but to be honest for how long you've been dealing with this issue along with the fact that you already tried cleaning them without success it might just be time to replace the sensors themselves.

We do have the Valterra Horst Miracle Probe Sensors # T21301VP that will install right to existing 3/8 inch diameter holes in the tank or you can simply drill new holes if your current ones don't match in size. These particular sensors feature a Delrin body and Teflon tube that surround the sensor to prevent any liquid residue or sludge from sticking. This essentially prevents the sensor reading problems that you have been having from happening again.

Four probes are included for your black water tank.

helpful expert reply by:
1
Chris R

Products Referenced in This Question


Product Page this Question was Asked From


Q & A Icon

Similar Expert Q&A Pages

See More Q&A Expert Answers >>