Troubleshooting Delayed Response from HydraStar EOH Actuator

Question:

I have a triple axle disc brake hyd / electric brake set up When you apply brakes the pump runs - it takes 4-5 seconds before you hear the motor load and the brakes apply - once applied they work I have bleed the brakes several times at the motor and each wheel no air With the trailer off the ground each brake does work basically it has a long delay Any ideas would be appreciated thank you

0

Expert Reply:

Some trailer brake controllers will not function correctly with an electric-over-hydraulic brake actuator like the # HydraStar # HBA16.

This is true of both proportional and time-delay controller types. If you are using a time-delayed type controller that IS compatible with an EOH setup, such as the Curt Venturer # C51110 or the Hayes Engage # HA81760, then the time delay is normal since that is the nature of this type of controller.

I linked two pages that show all of the time-delay and proportional controllers that are compatible with EOH systems.

If you are using a proportional type EOH-compatible controller such as the Prodigy P2 # 90885 or P3 # 90195 you should not experience much delay at all from the time you press the manual override to the time the pump kicks in.

expert reply by:
0
Adam R

Products Referenced in This Question






Product Page this Question was Asked From


Follow up Questions

What do you think?

* e-mail address format: [email protected]

I would like an email notification if someone replies to my comment

Similar Expert Q&A Pages

See More Q&A Expert Answers >>