Select Your Vehicle

View Cart

No Signal when the Brakes are Applied After Brake Controller Installation on a 1995 GMC Pickup


I have one of your boxes in my silverado and it works great. I put one in my 95 gmc tonight and there is nothing showing when I apply the brakes. The silverado has a tow package so it just plugged in, the gmc was wired in so wasnt sure if it would show the percent applied or not when the brakes are applied.

asked by: Donnie P

Expert Reply:

It sounds to me as if you do not have the red brake switch wire or the black power wire from the Agility brake controller, # HM47295, connected to the correct circuit.

Use a circuit tester, like part # 3808, to test the black wire first. You should have 12 volt power at all times going into the brake controller. If not you will need to find a constant 12 volt power source. We recommend using 10 gauge wire, # 10-2-1, and a 30 amp circuit breaker, # PK54530, inline on the power wire and attaching the power and ground wires to the vehicle battery.

Next, test the red brake switch wire. This wire should show power only when the brake pedal is pressed. If you do not have power on the red brake wire, you will need to locate the correct wire at the brake pedal switch to splice into. On the Chevrolet trucks this wire is light blue in many cases, check with the tester to be sure.

We have a brake controller installation video on a 1993 Suburban that should be helpful, see link.

The brake controller should definitely indicate the power percentage when the brakes are applied and there is a trailer connected to the vehicle 7-Way.

expert reply by: Bob G

Robert G

Have a question for the experts? click here.

Products Referenced in This Question

Product Page this Question was Asked From

More Answers about Brake Controller >

Recently Viewed Products

Stay Connected

Subscribe to email newsletter


privacy - we don't send unsolicited email reviews

All images, layout and content copyright